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LIMITED WARRANTY

 

Opcode Systems, Inc. warrants the SONICport and SONICport Optical against defects in materials and 
workmanship for a period of one (1) year from the date of original retail purchase.

If you discover a defect, first write or call Opcode Systems, Inc. at (650) 429-2349 to obtain a Return 
Merchandise Authorization Number (no service will be performed on any product returned without 
prior authorization). If the product needs to be returned to Opcode, please attach your name, address, 
telephone number, a description of the problem, and a copy of the dated bill of sale as proof of pur-
chase. Write the Return Merchandise Authorization (RMA) Number clearly on the outside of the 
package and all correspondence. Upon receiving the returned product, Opcode Systems, Inc. will 
then, at its option, repair, replace, or refund the purchase price of the product.

This warranty applies only to the SONICport and SONICport Optical; Opcode software is warranted 
separately.

This warranty does not apply if the product has been damaged by accident, abuse, misuse, or misappli-
cation, or has been modified without the written permission of Opcode Systems, Inc.

All implied warranties, including implied warranties of merchantability and fitness for a particular pur-
pose, are limited in duration to one (1) year from the original date of retail purchase of this product. 
The warranty and remedies set forth above are exclusive and in lieu of all others, oral or written, 
express or implied.

Opcode Systems, Inc. is not responsible for special, incidental, or consequential damages resulting 
from any breach of warranty, or under any legal theory, including lost profits, downtime, good-will, 
damage to or replacement of equipment and property.

Some states do not allow the exclusion or limitation of implied warranties or liability for incidental or 
consequential damages, so the above limitation or exclusion may not apply to you. This warranty gives 
you specific legal rights, and you may also have other rights which vary from state to state.

Except to the extent prohibited by law, all implied warranties made by Opcode Systems, Inc. in con-
nection with this manual and software are limited in duration to ninety (90) days from the date of 
original purchase, and no warranties, whether express or implied, shall apply to this product after said 
period.

Opcode Systems, Inc. makes no warranty or representation, either express or implied, with respect to 
the software described in this manual. This software is sold “as is.” The purchaser assumes the entire 
risk as to its quality and performance. Under no circumstances shall Opcode Systems, Inc. be liable for 
any loss or damage, direct, consequential, or incidental, arising out of the use or inability to use this 
product.

Some states do not allow limitations on how long an implied warranty lasts or the exclusion or limita-
tion of incidental or consequential damages, so the above limitations or exclusions may not apply to 
you.



 

TRADEMARKS

 

SONICport and SONICport Optical are trademarks of Opcode Systems, Inc. Pentium is a registered 
trademark of Intel Corporation. Windows is a trademark of Microsoft Corporation. Macintosh is a 
trademark of Apple Computer, Inc. All other products and brand names are trademarks or registered 
trademarks of their respective companies.

 

FCC RADIO FREQUENCY INTERFERENCE

 

This equipment has been tested and found to comply with the limits for a Class B digital device, pursu-
ant to Part 15 of the FCC Rules.

These limits are designed to provide reasonable protection against harmful interference in a residen-
tial installation. This equipment generates, uses, and can radiate radio frequency energy and, if not 
installed and used in accordance with the instructions, may cause harmful interference to radio com-
munications. However, there is no guarantee that interference will not occur in a particular installation. 
If this equipment does cause harmful interference to radio or television reception, which can be deter-
mined by turning the equipment off and on, the user is encouraged to try to correct the interference by 
one or more of the following measures:

• Reorient or relocate the receiving antenna of the affected radio or television.
• Increase the separation between the equipment and the affected receiver.
• Connect the equipment and the affected receiver to power outlets on separate circuits.
• Consult the dealer or an experienced radio/TV technician for help.

 

Modifications

 

: Changes or modifications not expressly approved by Opcode Systems, Inc. could void 
the user’s authority to operate the equipment, per FCC regulations.

 

Shielded Cables

 

: Shielded cables must be used with this equipment to maintain compliance with 
FCC regulations.

Declaration of Conformity

We, Opcode Systems, Inc.,
365 East Middlefield Road

Mountain View, CA 94043 USA
(650) 429-2400

declare under our sole responsibility that the products

Opcode SONICport
and

Opcode SONICport Optical

comply with Part 15 of FCC Rules. Operation is subject to the following two conditions: (1) this device 
may not cause harmful interference, and (2) this device must accept any interference received, includ-
ing interference that may cause undesired operation.



 

CSA RADIO FREQUENCY INTERFERENCE

 

This Class B digital apparatus meets all the requirements of the Canadian Interference-Causing Equip-
ment Regulations.

Cet appareil numérique de la classe B respecte toutes les exigences du Règlement sur le matériel 
brouilleur du Canada.

Declaration Of Conformity

We, Opcode Systems, Inc., of
365 East Middlefield Road

Mountain View, CA 94043 USA

declare under our sole responsibility that the products

SONICport and SONICport Optical, digital audio interfaces
for PC compatible computers,

to which this declaration relates
is in conformance with the following standards:

EN55022:1987
EN50082-1:1992
IEC 801-2:1984
IEC 801-3:1984
IEC 801-4:1988

following the provisions of the 89/336/EEC Directive.
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CHAPTER 1: Introduction to the 
SONICport

 

Thank you for purchasing the Opcode SONICport, an easy to install 
USB digital audio interface for your PC compatible. With it, you can 
transfer digital audio between your computer and S/PDIF digital audio 
devices such as DAT recorders, MiniDiscs, and digital multitracks. In 
addition, the analog inputs and outputs provide for more general pur-
pose audio recording and playback.

 

What’s Included

 

Your SONICport package includes the following:

• SONICport;
• 2-meter USB cable;
• PC disk with SONICport Config software;
• SONICport Manual;
• Technical Support Information booklet;
• User registration card.

 

System Requirements

 

To use the SONICport, you must have the following:

• Pentium 133 or faster, with Windows 98 installed;
• USB port or USB hub;
• Windows 98 CD (for driver installation).
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About the SONICport

 

Figure 1.1: SONICport, top view

 

Because of its elegant design, the SONICport is very easy to install and 
use. Quite simply, the SONICport consists of a USB connector, a 
S/PDIF input and output, an analog stereo (minijack) input and output, 
and a green input LED.

The SONICport connects to your computer via the Universal Serial 
Bus (USB). USB provides high-speed communication with up to 127 
devices, lets you plug and unplug devices without powering off your 
computer, and even auto-detects and configures hardware.

 

Figure 1.2: SONICport, left side

 

The SONICport’s 

 

USB connector

 

 comes from the factory with a 
2-meter USB cable already connected; the other end of this cable con-
nects to your computer’s USB port or hub. If desired, you can remove 
the provided USB cable and replace it with another longer one. It is not 
recommended, however, that you use USB extension cables with the 
SONICport.

USB connector

USB cable, B-connector
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IMPORTANT: Never plug or unplug the SONICport from your computer’s 
USB port while recording or playing audio (or when Instant Playback is 
on). This could in some instances cause your computer to crash.

 

The SONICport’s 

 

S/PDIF

 

 

 

IN

 

 jack connects to and receives audio from 
the digital output of your audio devices. The 

 

S/PDIF OUT

 

 jack con-
nects to and sends audio to the digital input of your audio devices. 

The type of S/PDIF connectors you have depends on which version of 
the SONICport you own:

•

 

SONICport

 

: The SONICport uses S/PDIF-COAXIAL (RCA-type) 
unbalanced connectors, white for the input and red for the output. 
Don’t confuse these connectors with analog RCA connectors, com-
monly found on home stereo equipment (never plug the 
SONICport’s S/PDIF jacks into an analog connector). Use high-
quality RCA cables to connect to your digital audio devices.

 

Figure 1.3: SONICport, right side

 

•

 

SONICport Optical

 

: The SONICport Optical uses S/PDIF-
OPTICAL connectors (often referred to as Toslink fiber-optic).
For this unit, use fiber-optical cables to connect to your digital 
audio devices. The SONICport Optical ships from the factory with 
caps on both optical connectors; when not connected to a digital 
audio device, make sure to leave these caps plugged in.

 

Figure 1.4: SONICport Optical, right side

Coaxial IN

Input LED

OUT—

Optical IN

Input LED

OUT—
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The SONICport also has a pair of stereo minijacks for analog input and 
output. These 3.5mm stereo connectors (similar to the headphone 
jacks on portable cassette players) transmit and receive line level audio 
signals.

 

Figure 1.5: SONICport, left side

 

Use the SONICport’s 

 

Analog IN

 

 to record a stereo analog signal, such 
as that from a home stereo. Connect the 

 

Analog OUT

 

 to an audio 
mixer to monitor or record the SONICport’s audio signal—you can 
even plug a pair of headphones directly into this jack.

 

NOTE: Many audio devices transmit and receive stereo audio signals via 
separate right and left jacks. To connect the SONICport to these devices, 
use a 3.5mm stereo minijack to dual RCA (or 1/4”) cable.

 

Whenever the SONICport transmits audio, it is sent to both the 
S/PDIF OUT and Analog OUT. However, the unit can only receive 
audio from one of its input ports: either the S/PDIF IN or Analog IN. 
The setting for Sample Rate/Type in the SONICport Config application 
determines which signal will be used (see 

 

Analog Input

 

 (pg. 10)).

The SONICport also has a green 

 

input

 

 

 

LED

 

 that becomes lit when-
ever the unit receives digital audio via its S/PDIF input jack. Use this 
LED to monitor whether the unit is successfully connected to your PC 
and receiving digital audio from your signal source.

Analog OUT IN—
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CONNECTING TO A PC

 

Before connecting the SONICport to your PC you must first install the 
SONICport Config software. This software allows you to reconfigure 
the unit’s sample rate and bit depth, put it in Analog mode, and enable 
“Instant Playback.”

To install the SONICport Config software:

 

a

 

Disconnect all USB devices from your computer.

 

b

 

Close all Windows applications.

 

c

 

Insert the PC disk included with your SONICport package and 
double-click the 

 

Setup

 

 program.

 

d

 

Follow the prompts within the Setup program as requested.

 

The SONICport Config software is copied to your computer, and will 
eventually appear in the Windows Taskbar.

 

e

 

When finished, exit the installer and restart Windows for changes to 
take effect.

 

f

 

After restarting, reconnect your USB devices.

 

In recognizing your USB devices, Windows may take several seconds to 
rebuild its driver database.

 

When first connecting to your PC, the SONICport is automatically 
detected and you are prompted by Windows to install the necessary 
USB drivers. To complete the following installation procedure, you will 
need your Windows 98 CD.

 

a

 

Make sure all Windows applications are closed.

 

b

 

If it’s not already attached, connect the “B” end of the provided USB 
cable to the SONICport’s USB jack (see Figure 1.2 on page 2). 
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c

 

Connect the other “A” end of the USB cable to your computer’s 
USB port or hub.

 

Figure 1.6: Connecting to a USB port

 

After several seconds Windows identifies the SONICport as a USB 
audio device and launches the Add New Hardware Wizard.

Click the 

 

Next

 

 button to continue.

 

d

 

The following dialog prompts you to specify what “you want 
Windows to do.”

 

Select the option for “Search for the best driver for your device,” then 
click the 

 

Next

 

 button.

USB cable, A-connector
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e

 

In the following dialog you must specify where Windows will search 
for the necessary USB driver.

 

Uncheck the options for “Floppy,” “CD-ROM,” “Microsoft Windows 
Update,” and “Specify a location.” Then click 

 

Next

 

.

 

NOTE: If you check the option for “Microsoft Windows Update,” Windows 
will try to access its online drivers via the Web.

 

f

 

When prompted, insert your Windows 98 CD and click 

 

OK

 

.

 

g

 

Once Windows has located the USB driver to be installed, click the 

 

Next

 

 button.

 

Windows installs the driver from your Windows 98 CD. 

 

h

 

When completed, click 

 

Finish

 

 to exit.

 

NOTE: The SONICport requires that three USB drivers be installed: USB 
Composite Device, USB Human Interface Device, and USB Audio Device. 
When first connecting the SONICport, you will have to perform the Wizard 
steps outlined above for each driver not already installed on your system.

In addition, Windows may in some instances prompt you to reinstall these 
drivers if you plug the SONICport into a different USB port, or if you 
reconfigure the SONICport (as described on page 9).

 

Connecting Multiple SONICports/DATports

 

If you need even more audio inputs and outputs for your PC, you can 
connect additional SONICports or DATports (up to 4 total devices). Of 
course, you’ll need a USB port for each device. When adding a new 
device, you may be prompted by the Add New Hardware Wizard to 
install the necessary USB drivers.
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USING THE SONICPORT CONFIG SOFTWARE

 

Once the SONICport Config software is installed and the unit is suc-
cessfully connected to your PC, an icon appears in the “task tray” 
section of the Windows Taskbar. Double-clicking this icon launches 
the SONICport Config program, where you can reconfigure the unit’s 
sample rate and bit depth, name individual SONICports, enable Analog 
input, and enable “Instant Playback” (discussed on page 12).

If using multiple SONICports, the Input Sample Rate, Bit Depth, and 
Name can be different for each unit. The Device menu at the top of the 
window determines which SONICport will be reconfigured when click-
ing the 

 

Set

 

 button. The Instant Playback Settings, on the other hand, 
are shared by all connected SONICports.

 

NOTE: Disconnecting the SONICport from your PC’s USB port will 
cause the icon to go away in the Taskbar, reconnecting will make it reap-
pear. In both instances, the icon’s LED will blink red for a few seconds, 
indicating a change in the connection status.

When Instant Playback is enabled, and the SONICport is connected, a 
green LED will continuously blink in the SONICport Config icon. When 
Instant Playback is off, the green LED will remain lit but not blink.

Double-click
icon to open the
SONICport Config app
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Sample Rate and Bit Depth

 

When recording digital audio with the SONICport via its S/PDIF IN, 
you must specify the Sample Rate and Bit Depth (so it matches the set-
tings used by the digital audio source, and your recording software). 
The supported bit depths and sample rates, which are specified with the 
SONICport Config software, are as follows:

•

 

Bit Depths

 

: 16 or 24
Most users will likely stick with 16 bit, which is the bit depth used 
for audio CDs, DATs, and MiniDiscs. The higher bit depth of 24 is 
provided for those using high end digital audio hardware and soft-
ware—check your manufacturer’s documentation to see if this bit 
depth is supported.

•

 

Sample Rates

 

: 32, 44.1 or 48 kHz
44.1 kHz is the sample rate used for audio CDs and MiniDiscs. 
Most DAT players use 48 kHz by default, but may also support 44.1 
kHz. 32 kHz is often used in radio production.

While the Input Sample Rate and Bit Depth can be different for each 
connected SONICport, the Instant Playback Sample Rate (see page 12) 
is shared for all connected SONICports.

If playing audio from multiple audio applications at the same time, make 
sure that all files are using the same sample rate.

When Instant Playback is disabled, the SONICport will play back digi-
tally (via the S/PDIF OUT) at any of its 3 supported sample rates; audio 
files with other sample rates will not successfully play. However, if 
using the SONICport’s Analog OUT, audio files with sample rates of 8-
48k 

 

will

 

 play successfully.

When Instant Playback is enabled (see page 12), audio files of any 
sample rate will play back at the Instant Playback Sample Rate using on-
the-fly sample rate conversion (as necessary).

 

NOTE: The SONICport’s default configuration uses a Bit Depth of 16 
with the input mode set to Analog. If you intend to use the SONICport’s 
S/PDIF input, make sure to switch the Sample Rate/Type setting to one of 
the three sample rate options. See Reconfiguring the SONICport (pg. 10).
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Analog Input

 

While the SONICport always sends audio to both the Analog and 
S/PDIF outputs, it can only receive one or the other as its input source. 
The 

 

Sample Rate/Type

 

 option in the SONICport Config software 
determines whether the unit will receive digital or analog.

 

Figure 1.7: Sample Rate/Type, SONICport Config software

 

If you choose one of the three sample rates (32000, 44100, or 
48000 Hz), the SONICport will record from its S/PDIF input. If, on the 
other hand, you choose 

 

Analog

 

, it will record from its Analog input. 
For details on putting the unit into Analog mode, see the following sec-
tion 

 

Reconfiguring the SONICport

 

 (pg. 10).

 

Reconfiguring the SONICport

 

To reconfigure the SONICport’s Bit Depth or Input Sample Rate, 
enable Analog input, or enter a unique name for the device:

 

a

 

Double-click the 

 

SONICport

 

 

 

Config

 

 icon in the Windows Taskbar.

 

If there is no icon present for the SONICport Config software, you have 
either not installed it, or your SONICport is currently not connected to 
your PC. See 

 

Connecting to a PC

 

 (pg. 5) for additional information.

 

b

 

If using more than one SONICport, choose from the Device menu 
which device you will reconfigure.
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c

 

Specify the 

 

Bit Depth

 

 and

 

 Input Sample Rate

 

. 

 

If you will be recording from the SONICport’s Analog IN, choose the 
“Analog” option. When the SONICport is in Analog mode, the signal from 
the S/PDIF IN is ignored.

d If desired, type in a custom name for the SONICport in the Name 
field.

e Click the Set button.

The SONICport’s configuration info is rewritten and then verified.

When prompted, restart Windows for changes to take effect. A reconfig-
ured SONICport will not be available until after restarting.
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Instant Playback (for S/PDIF output)

To ensure the highest possible audio performance over USB (very low 
“jitter”), and allow compatibility with the widest range of S/PDIF 
devices, the SONICport waits approximately 3-5 seconds before play-
ing digital audio.

If you want more immediate response times on playback for digital 
audio, enable “Instant Playback” mode from the SONICport Config 
software. Whenever doing a final transfer of digital audio to another 
device from the SONICport, make sure to use Instant Playback—
otherwise, you’ll have to allow for a 3-5 second pre-roll time for the 
SONICport to cleanly enter play mode.

There are a few important things to keep in mind when enabling 
Instant Playback mode...

• Avoid unplugging the SONICport, this could in some instances 
lead to a crash.

• When playing audio, make sure the sample rate for the audio files 
matches that of the Instant Playback Sample Rate (as indicated in 
the SONICport Config program). 
Failing to do so will likely cause the unit to enter into a state where 
it will use on-the-fly sample rate conversion for playback, resulting 
in reduced audio fidelity. If you find yourself in this state, open and 
close the SONICport Config software to reset the unit—this will 
ensure that the SONICport will play optimally at its own sample 
rate (unless, of course, it encounters a file at a different rate).

• The Instant Playback Sample Rate is used for all connected 
SONICports, which means that each device will play back at that 
rate.

Instant Playback also allows the SONICport to continually transmit 
S/PDIF information to connected audio devices, even when the 
SONICport is not playing. This is useful because some DAT players 
will not enter record mode until there is a S/PDIF signal present.

NOTE: Instant Playback only affects the audio transmitted to the SONIC-
port’s S/PDIF OUT. If you are only using the device’s Analog OUT, there 
is no need to enable Instant Playback.
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Enabling Instant Playback

To enable Instant Playback for all connected SONICports:

a Double-click the SONICport Config icon in the Windows Taskbar.

If there is no icon present for the SONICport Config software, you have 
either not installed it, or your SONICport is currently not connected to 
your PC. See Connecting to a PC (pg. 5) for additional information.

b Once the SONICport Config Window is open, place a checkmark 
next to Enabled to turn on Instant Playback.

c Next choose one of the three Instant Playback sample rates (32000, 
44100, or 48000).

This sample rate should match that of the intended audio files you will 
play.

d Click the Close button to close the SONICport Config Window.

Once Instant Playback is enabled, a green LED will continuously blink in 
the SONICport Config icon.

IMPORTANT: Do not unplug your SONICport when Instant Playback is 
enabled. Doing so may in some instances cause your computer to crash.

Flashing green LED indicates that
Instant Playback is on
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CHAPTER 2: Recording and Playing 
Audio

USING WINDOWS APPLICATIONS

Once the SONICport is connected and its drivers are installed, it 
appears in Windows applications as “USB Audio Device (1),” see 
Figure 2.1. The number in parenthesis may vary depending on whether 
other audio devices are installed. In fact, this number may even change 
for the SONICport device if you add or remove other audio hardware 
from your computer; or, in some instances, if you restart Windows. 
When using multiple SONICports, their drivers appear separately and 
are uniquely numbered.

Figure 2.1: SONICport selected in the Windows Sound Recorder

Whenever you disconnect a SONICport, its driver no longer appears as 
available in Windows. When reconnecting the unit, however, its driver 
automatically becomes available again.

To use the SONICport in a Windows audio application, simply make 
sure the appropriately numbered “USB Audio Device” is selected as the 
recording or playback device. This chapter contains some basic exam-
ples of recording and playing audio with the SONICport.
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Windows System Sounds and the SONICport

Whenever connecting the SONICport to your PC, it automatically 
becomes selected in the Multimedia Control Panel (see Figure 2.2). 
This means that your Windows system sounds will play through the 
SONICport, which is something you’ll wish to avoid when performing 
digital audio transfers.

Figure 2.2: Multimedia Control Panel

In addition, since all system sounds are 22 kHz wave files and the 
SONICport uses a higher sample rate for digital output (32, 44.1, or 
48 kHz), these sounds may not play back reliably.

It is therefore suggested that you deselect the SONICport’s driver 
(“USB Audio Device”) in the Multimedia Control Panel whenever the 
unit is connected to your PC.
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SOUND RECORDER

To configure the Windows Sound Recorder for use with the 
SONICport:

a From the Window’s Taskbar choose Programs>Accessories>
Entertainment>Sound Recorder.

The Sound Recorder application opens.

b Choose Edit>Audio Properties.

The Audio Properties dialog opens.

Set the Preferred Device for Playback and Recording to USB Audio 
Device. Then click OK.

IMPORTANT: Configuring the Sound Recorder for use with the SONIC-
port is the same as selecting the SONICport’s driver in the Multimedia 
Control Panel. When finished with Sound Recorder, make sure to dese-
lect the SONICport in the Multimedia Control Panel—otherwise the 
Windows system sounds will play through the SONICport. 
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To record a new audio file in the Windows Sound Recorder with the 
SONICport:

a Choose File>New to open a new sound file.

b Next make sure the Sound Recorder is configured to record at the 
desired sample rate and bit depth. Choose  File>Properties.

The Properties for Sound dialog opens. With the “Choose from” pop-up 
set to All formats, click the Convert Now button.

The Sound Selection dialog opens.

c In the Sound Selection dialog, set the Format pop-up to PCM and 
the Attributes pop-up to 44,100 Hz, 16 Bit, Stereo. Then click 
the OK button.

d If recording from a digital source (DAT player, MiniDisc, digital 
multitrack, etc.), connect the source device’s S/PDIF output to the 
SONICport’s S/PDIF IN.

In addition, make sure the source device and SONICport are both config-
ured for 44.1 kHz and 16 bit.

e If recording from an analog source (like a home stereo), connect the 
source device’s audio output to the SONICport’s Analog IN.

In addition, make sure the SONICport is configured for 16 bit and Analog 
input. See Reconfiguring the SONICport (pg. 10) for details.
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f Click the Record button in Sound Recorder to begin recording.

g Initiate playback from your audio source.

If recording from a digital source, the SONICport’s green input LED will 
become lit when receiving the audio.

h When finished recording, click the Stop button in Sound Recorder 
and stop playback from your audio source.

i Choose File>Save to save the recorded file.

When prompted, enter a name for the newly recorded sound file.

To play an audio file in Sound Recorder with the SONICport:

a Choose File>Open to open the desired sound file.

b Connect the SONICport’s S/PDIF OUT or Analog OUT to the desired 
destination(s).

If you will be recording the output of the SONICport, place the external 
recording device in record mode.

c Click the Sound Recorder’s Play button.

Playback begins and the audio signal is sent to both outputs (S/PDIF 
and Analog) of the SONICport.

NOTE: If using the SONICport’s S/PDIF output, make sure to enable 
“Instant Playback” for immediate playback response times. See page 12 
for details.

d When finished, click Sound Recorder’s Stop button.
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COOL EDIT PRO 1.1

To configure Syntrillium’s Cool Edit Pro for use with the SONICport:

a Double-click the Cool Edit Pro icon to launch the application.

b Choose Options>Settings.

The Settings dialog opens.

Click the “Devices” tab and then set the Waveform Playback and Wave-
form Record to USB Audio Device. Then click the OK button.
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To record a new audio file in Cool Edit Pro with the SONICport:

a Choose File>New Session.

When prompted, specify a Resolution of 16-bit along with a Sample 
Rate of 44100. Then click the OK button.

b Choose View>Multitrack View.

Cool Edit Pro switches from Edit Waveform View to Multitrack View.

c In the Track Console, click the Record Device button for the 
desired track.

The Recording Device dialog opens.

In the Recording Device dialog, make sure the SONICport is the 
selected device. In addition, click the Stereo option, then click the OK 
button.
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d Next record-enable the desired track by clicking the R button in the 
Track Console.

e If recording from a digital source (DAT player, MiniDisc, digital 
multitrack, etc.), connect the source device’s S/PDIF output to the 
SONICport’s S/PDIF IN.

In addition, make sure the source device and SONICport are both config-
ured for 44.1 kHz and 16 bit.

f If recording from an analog source (like a home stereo), connect the 
source device’s audio output to the SONICport’s Analog IN.

In addition, make sure the SONICport is configured for 16 bit and Analog 
input. See Reconfiguring the SONICport (pg. 10) for details.

g Click the Record button in Cool Edit Pro to begin recording.

h Initiate playback from your audio source.

If recording from a digital source, the SONICport’s green input LED will 
become lit when receiving the audio.

i When finished recording, click the Stop button in Cool Edit Pro and 
stop playback from your audio source.

j Choose File>Save Session to save the recorded file.

When prompted, enter a name for the newly recorded sound file.

To play an audio file in Cool Edit Pro with the SONICport:

a Choose File>Open to open the desired sound file.

b Make sure Cool Edit Pro is in Multitrack View.
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c In the Track Console, click the Playback Device button for the 
desired track.

In the Playback Device dialog, make sure the SONICport is the selected 
device. Then click the OK button.

d Connect the SONICport’s S/PDIF OUT or Analog OUT to the desired 
destination(s).

If you will be recording the output of the SONICport, place the external 
recording device in record mode.

e Click Cool Edit Pro’s Play button.

Playback begins and the audio signal is sent to both outputs (S/PDIF 
and Analog) of the SONICport.

NOTE: If using the SONICport’s S/PDIF output, make sure to enable 
“Instant Playback” for immediate playback response times. See page 12 
for details.

f When finished, click Cool Edit Pro’s Stop button.
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CHAPTER 3: Tips and 
Troubleshooting

OPTIMIZING WINDOWS SETTINGS

For critical audio transfers you may wish to adjust several System set-
tings in Windows 98 for better performance. To access the following 
options, choose Start>Settings>Control Panel from the Windows 
Taskbar. Double-click the System icon, select the appropriate tab and 
proceed as outlined below:

• Automatic detection for inserted CD-ROMs
Device Manager Tab: Double-click CD-ROM and select your 
CD-ROM drive. Click the Properties button, select the Settings 
tab and uncheck “Auto insert notification.”

• Read-ahead optimization for hard disk
Performance Tab: Click the File System button and change the 
“Read-ahead optimization” slider from Full to None. 

• Write-behind caching for all drives
Troubleshooting Tab: While still in the File System Properties dia-
log, select the Troubleshooting tab and check “Disable write-
behind caching for all drives.”

You will have to restart Windows for these new settings to take effect. 

NOTE: For optimal performance with other Windows applications, you 
may wish to return these settings to their default values after completing 
your audio transfers.
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CORRUPTED CONFIGURATION MAP

If your computer crashes, or if you unplug your SONICport, while 
reconfiguring the device, its configuration info may become corrupted. 
If this happens the SONICport Config application will not be able to tell 
whether you have a DATport, SONICport, or SONICport Optical.

Figure 3.1: Choose Product dialog

This is not cause for alarm however. Simply launch the Config pro-
gram from the Windows Taskbar, highlight the device you own and 
click the Re-initialize using the selected product button. When the 
Config Window opens, make the desired selections for Bit Depth and 
Sample Rate/Type, then click the Set button. See Reconfiguring the 
SONICport (pg. 10) for details.

Figure 3.2: Reinitializing a SONICport
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USING BOTH SONICPORT AND DATPORT

It is possible to connect several of Opcode’s USB audio devices, such as 
a DATport and a SONICport, to a single computer. The maximum 
number of devices supported is 4.

Figure 3.3: Device menu listing SONICport and DATport

Multiple devices can even have different settings for Bit Depth and 
Input Sample Rate, and even unique names. The device menu at the top 
of the Config Window determines which unit will be configured with 
the Set button. Instant Playback settings, however, are common to all 
connected devices.

NOTE: The option for Analog input under Sample Rate/Type only 
appears if a SONICport or SONICport Optical is selected from the device 
menu. The DATport does not support Analog input.

In order to use different device types on your computer, you must have 
version 1.2 or later of the SONICport/DATport Config software. If you 
have an earlier version, remove it and install the latest version.
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